What are the System Requirements?

In order to use Big Universe, you must have high-speed Internet (bandwidth requirements vary based on number of users and usage) and Adobe Flash for full functionality.  For the best experience, keep your browser up to date by
installing the latest available version. The minimum browser requirements are:

  • Microsoft® Internet Explorer 9.0
  • Chrome 8.0
  • Safari 5.0
  • Mozilla Firefox 6.0
  • Opera 10.0

The writing tool, member published books, and read aloud books are not supported
for devices that do not support flash, such as iOS. All other features are
available through the device's web browser.

A modern HTML5 capable browser is required for all devices.  For Kindle Fire and other Android devices, we recommend installing the latest version of Google Chrome as older versions of Amazon's Silk browser may have limited support.

Powered by Zendesk